Error in Dependency when doing yum update/install clamd package

When updating or installing clamd, I always get the following error:

  
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: mirrors.linode.com
 * epel: mirrors.aliyun.com
 * extras: mirrors.linode.com
 * updates: mirrors.linode.com
Resolving Dependencies
--> Running transaction check
---> Package clamav-scanner.noarch 0:0.98.7-1.el7 will be obsoleted
--> Processing Dependency: clamav-scanner = 0.98.7-1.el7 for package: clamav-scanner-systemd-0.98.7-1.el7.noarch
---> Package clamav-server.x86_64 0:0.98.7-1.el7 will be obsoleted
--> Processing Dependency: clamav-server = 0.98.7-1.el7 for package: clamav-server-systemd-0.98.7-1.el7.noarch
---> Package clamd.x86_64 0:0.100.1-3.el7 will be obsoleting
--> Processing Dependency: clamav-lib = 0.100.1-3.el7 for package: clamd-0.100.1-3.el7.x86_64
--> Processing Dependency: clamav-filesystem = 0.100.1-3.el7 for package: clamd-0.100.1-3.el7.x86_64
--> Processing Dependency: libclamav.so.7(CLAMAV_PUBLIC)(64bit) for package: clamd-0.100.1-3.el7.x86_64
--> Processing Dependency: libclamav.so.7(CLAMAV_PRIVATE)(64bit) for package: clamd-0.100.1-3.el7.x86_64
--> Processing Dependency: libclamav.so.7()(64bit) for package: clamd-0.100.1-3.el7.x86_64
--> Finished Dependency Resolution
Error: Package: clamd-0.100.1-3.el7.x86_64 (epel)
           Requires: libclamav.so.7(CLAMAV_PUBLIC)(64bit)
Error: Package: clamav-server-systemd-0.98.7-1.el7.noarch (@epel)
           Requires: clamav-server = 0.98.7-1.el7
           Removing: clamav-server-0.98.7-1.el7.x86_64 (@epel)
               clamav-server = 0.98.7-1.el7
           Obsoleted By: clamd-0.100.1-3.el7.x86_64 (epel)
               clamav-server = 0.100.1-3.el7
Error: Package: clamav-scanner-systemd-0.98.7-1.el7.noarch (@epel)
           Requires: clamav-scanner = 0.98.7-1.el7
           Removing: clamav-scanner-0.98.7-1.el7.noarch (@epel)
               clamav-scanner = 0.98.7-1.el7
           Obsoleted By: clamd-0.100.1-3.el7.x86_64 (epel)
               clamav-scanner = 0.100.1-3.el7
Error: Package: clamd-0.100.1-3.el7.x86_64 (epel)
           Requires: libclamav.so.7()(64bit)
Error: Package: clamd-0.100.1-3.el7.x86_64 (epel)
           Requires: libclamav.so.7(CLAMAV_PRIVATE)(64bit)
Error: Package: clamd-0.100.1-3.el7.x86_64 (epel)
           Requires: clamav-lib = 0.100.1-3.el7
           Installed: clamav-lib-0.98.7-1.el7.x86_64 (@epel)
               clamav-lib = 0.98.7-1.el7
Error: Package: clamd-0.100.1-3.el7.x86_64 (epel)
           Requires: clamav-filesystem = 0.100.1-3.el7
           Installed: clamav-filesystem-0.98.7-1.el7.noarch (@epel)
               clamav-filesystem = 0.98.7-1.el7
 You could try using --skip-broken to work around the problem

 You could try running: rpm -Va --nofiles --nodigest
  

After hours of debugging, I discovered that the clamav package is excluded in yum configuration file (/etc/yum.conf):

  
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=5
bugtracker_url=http://bugs.centos.org/set_project.php?project_id=23&ref=http://bugs.centos.org/bug_report_page.php?category=yum
distroverpkg=centos-release

exclude=clamav*
  

That line must be auto generated or added by Virtualmin web hosting control panel. As solution, remove the line or comment it:

  
vi /etc/yum.conf
  
  
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=5
bugtracker_url=http://bugs.centos.org/set_project.php?project_id=23&ref=http://bugs.centos.org/bug_report_page.php?category=yum
distroverpkg=centos-release

#exclude=clamav*
  
Tags

Add new comment

Restricted HTML

  • Allowed HTML tags: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type> <li> <dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id>
  • Lines and paragraphs break automatically.